Release process not completing or commit changes hanging during the release process
Incident Report for Copado Solutions
Resolved
We can confirm that any job queues have now cleared. Should you see any jobs still in progress for longer than usual, please cancel and restart them.
Posted May 11, 2022 - 19:43 UTC
Update
Due to issues derived from a Salesforce outage, we are seeing jobs queueing.

Clients that are using Heroku can discontinue attempting to retry their jobs at this time. Jobs that show as started will be completed, however, may take longer to complete. You no longer need to attempt to cancel and restart.
Posted May 11, 2022 - 16:17 UTC
Identified
We are aware some clients are having issues during the release process. You may see jobs not completed or hanging during the process. Our team is investigating the cause of the error and will provide updates as quickly as possible. We apologize for the inconvenience.
Posted May 11, 2022 - 14:30 UTC
This incident affected: North America (CICD) and EMEA (CICD).