Salesforce Performance Degradation
Incident Report for Copado Solutions
Resolved
We are no longer seeing impacted jobs. This issue appears to have been related to Incident ID 12223 (https://status.salesforce.com/incidents/12223). We are working with Salesforce to confirm.
Posted Jan 24, 2024 - 01:47 UTC
Update
We are still awaiting a response from the Salesforce team; we continue to see job performance impacted by delays in metadata retrieval.
Posted Jan 23, 2024 - 21:11 UTC
Identified
We have identified multiple jobs, across various customers, which are being impacted by delays in metadata retrieval from Salesforce.

While this apparent performance degradation is currently not listed on status.salesforce.com, we have engaged Salesforce directly for further clarity. In our initial testing, it appears the impact is limited to Hyperforce instances.

In the majority of cases, this issue simply impacts the duration of the associated job. In limited examples we have seen jobs fail due to timeouts as a result of this delayed response.

We will update this incident as more information is available.
Posted Jan 23, 2024 - 17:55 UTC
This incident affected: North America (CICD, Copado Robotic Testing, Essentials), EMEA (CICD), and APAC (CICD).