After the hotfix, our monitoring shows no new instances of this error occurring- this incident is being marked Resolved.
Posted Mar 04, 2025 - 16:40 UTC
Monitoring
The hotfix has been released. We will monitor the impact for a short period and update this incident to Resolved.
Posted Mar 04, 2025 - 15:06 UTC
Update
Our engineering team has reviewed this issue further, and confirmed that customers on Salesforce patch 9.10 are also affected, due to another object not included in the library.
They have prepared a hotfix which addresses all cases. This hotfix is being tested now and will be released shortly.
Posted Mar 04, 2025 - 13:34 UTC
Identified
It appears that Salesforce has introduced a change to the Partner WSDL in patch 9.9 which is unexpectedly returning JSON for the certain objects in the describe call.
This is affecting customers on this version in their ability to get metadata, and to create snapshots.
We have temporarily implemented a method to ignore this object in the Salesforce Partner WSDL and have informed Salesforce of the issue.
Our engineering and infrastructure teams are engaged and we will share updates here as our investigation continues.
Posted Mar 03, 2025 - 22:35 UTC
This incident affected: North America (CICD), EMEA (CICD), and APAC (CICD).