Job Delays - Salesforce
Incident Report for Copado Solutions
Postmortem

Salesforce has shared the following incident as the root cause:

https://status.salesforce.com/incidents/10878

Posted Mar 16, 2023 - 18:09 UTC

Resolved
This incident has been resolved.
Posted Mar 15, 2023 - 22:19 UTC
Monitoring
Our monitoring shows that the frequency of this issue has reduced significantly. We will continue to monitor for now, and update this incident accordingly.
Posted Mar 15, 2023 - 21:15 UTC
Update
Based on further investigation, we have determined that delays in responses from Salesforce are also affecting a limited number promotion jobs with rollback enabled. This incident has been updated to describe the broader impact.
Posted Mar 15, 2023 - 19:47 UTC
Identified
We are aware some clients are experiencing interruptions resulting in delays with commit jobs while using Copado. Our team has investigated and concluded the issues are the result of delays when retrieving metadata through Salesforce.

Thus far, no performance degradation has been shared via https://status.salesforce.com/ but we are actively engaged with Salesforce support. We will share updates here as they become available.
Posted Mar 15, 2023 - 17:17 UTC
This incident affected: North America (CICD), EMEA (CICD), and APAC (CICD).