Salesforce Performance Degradation
Incident Report for Copado Solutions
Resolved
All jobs are running as expected. We are marking this incident as resolved.
Posted Jul 21, 2022 - 12:26 UTC
Update
We are still seeing examples of long-running jobs awaiting a response from Salesforce- this incident will remain in Monitoring status until we see further confirmation that the issue is entirely resolved.
Posted Jul 21, 2022 - 00:28 UTC
Monitoring
Salesforce has updated their incident statuses to indicate the performance degradation is resolved- but we are still seeing a number of long-running jobs that are awaiting responses from Salesforce.

We will continue to monitor and update this status when the issue appears to be fully resolved from our end.
Posted Jul 20, 2022 - 20:30 UTC
Identified
We are seeing multiple examples of customers' Copado performance being impacted by Salesforce performance degradation.

https://status.salesforce.com/

We are engaged with our internal infrastructure and engineering teams, as well as with Salesforce, to monitor the situation. We will share updates here as they become available.
Posted Jul 20, 2022 - 17:10 UTC
This incident affected: North America (CICD, Copado Robotic Testing), EMEA (CICD), and APAC (CICD).